Status.VerifyThisSeal.com Down
Resolved·Partial outage

SSL updates have propagated and status.verifythisseal.com now resolves to status.wharton.us with both HTTP and HTTPS request.

Tue, Oct 14, 2025, 06:08 AM
(2 weeks ago)
·
Affected components
Updates

Resolved

SSL updates have propagated and status.verifythisseal.com now resolves to status.wharton.us with both HTTP and HTTPS request.

Tue, Oct 14, 2025, 06:08 AM

Identified

While SSL propagates, http calls to status.verifythisseal.com are directing to status.wharton.us.

Tue, Oct 14, 2025, 05:31 AM(37 minutes earlier)

Identified

status.verifythisseal.com is inaccessible while SSL changes are implemented.

Tue, Oct 14, 2025, 05:03 AM(27 minutes earlier)

Identified

Incident ID (81)

Tue, Oct 14, 2025, 05:00 AM
Powered by

© 2025 Wharton USA, LLC. “Wharton™” is a trademark of Wharton USA, LLC. All rights reserved.